Aaron Parecki
Inspired by some #indieweb folks creating /caw pages on their websites, I made one of my own! Here you can listen to the most recent crow recorded from my house: aaronparecki.com/caw/
๐ Enterprise-Managed Authorization extension (aka Cross App Access) - eliminate the OAuth redirect and get tokens for an MCP server by requesting them from the enterprise IdP Read more about what these mean for you in my full post ๐ aaronparecki.com/2025/11/25/1...
I just finished adding BlueSky support to IndieLogin.com! Now you can log in to websites like indieweb.org with your BlueSky handle!
The folks at Stytch put together a really nice explainer website about it too! cimd.dev
The IETF OAuth Working Group has adopted the Identity Assertion Authorization Grant specification! datatracker.ietf.org/doc/draft-ie... This is the basis of Cross App Access (XAA), providing IT admins better visibility and control by configuring the app-to-app connections in their enterprise IdP.
Inspired by a question from @thisismissem.social, I wrote up a document describing how to apply DPoP (RFC9449) to the OAuth Device Flow (RFC8628). datatracker.ietf.org/doc/draft-pa...
In two weeks I'll be speaking at @mcpdevsummit.bsky.social in San Francisco! MCP has quickly reshaped how developers are building AI agents. My talk "Intro to OAuth for MCP Servers" will cover the basics of the MCP authorization protocol and set the stage for building secure MCP servers.
Aaron Parecki reposted
๐ค Speaker Spotlight: Aaron Parecki, Director of Identity Standards at @okta Learn how #OAuth applies to #MCP servers and why securing your #MCP server is critical To attend this session and more register at buff.ly/NzqdbNE @aaronpk.com #AI #LLM #ModelContextProtocol #MCPDevSummit
At long last, the OAuth working group has finished the Best Current Practice for OAuth 2.0 Security and it was just published as RFC9700! This has been a long time in the works, and I'm very thankful to everyone who has helped out with it over the years! www.rfc-editor.org/rfc/rfc9700....