dmarcian

dmarcian

@dmarcian.com

We're on a mission to spread DMARC across the globe to make email and the internet safer for all.

183 followers435 following531 posts

Pinned

𝙃𝙞 𝙩𝙝𝙚𝙧𝙚. 🦋 We’re here to help make the open security email controls of #DMARC, #SPF and #DKIM accessible to everyone.

Stay ahead in #DMARC and email security—all in one place. Our newsletter brings you the latest insights, expert advice, and practical resources to make email safer for everyone. Join tens of thousands of subscribers building a safer email ecosystem: dmarcian.com/newsletter

Online payments run on trust—and that includes every invoice and receipt sent in your brand's name. We break down Stripe's CNAME/TXT requirements, PCI DSS anti-phishing rules, and a roadmap to p=reject: dmarcian.com/stripe-secur... #Stripe #PCI #EmailSecurity

Most #DMARC projects don’t stall on #DNS; they stall on a person and who has no reason to answer your email’s request for help. AI won't fix human incentive problems or help you align teams. Getting an enterprise to p=reject takes a shift in mindset: dmarcian.com/dmarc-deploy...

Learn how to add a #DMARC record to your domain's #DNS in this simple tutorial. Here, we'll utilize GoDaddy's resources, and explore the simple process and how to apply it to other DNS providers. #dmarcian #EmailAuthentication

SPF is often misunderstood, and misconfigurations are easy to miss. To clear this confusion, we thought we'd release some SPF cleanup techniques for your reference: dmarcian.com/spf-record-c... #DMARC #EmailAuthentication #Guides #dmarcian

Missed the live session? In partnership with the Certified Senders Alliance (CSA), Steffen Siguda (CISO, ams OSRAM) reveals the unvarnished reality behind their DMARC journey and our very own Matia shares expert insights on DMARC deployments: youtu.be/5BtazPIn8kQ?...

youtu.beFrom Zero to DMARC Enforcement — And Why It Was Worth ItJoin Matia Boldrini, Professional Services Representative at dmarcian, and Steffen Siguda, Corporate Information Security Officer at ams OSRAM Group, for a webinar all about the DMARC journey. Learn…

Our DMARC Services are built to meet organizations where they are, and support even the most complex infrastructures. Not sure which service fits your needs? Take a look at the support we offer or book a free brief consultation: dmarcian.com/dmarc-servic... #DMARC #EmailAuthentication #Enterprise

This guide walks you through publishing MTA-STS (Mail Transfer Agent Strict Transport Security) policies for multiple domains using a single #Cloudflare Worker:https://dmarcian.com/mta-sts-cloudflare-guide/ #Guides #DMARC #EmailAuthentication

Want to see how an email was processed and spot delivery problems instantly? Try our Email Header Analyzer to trace routing, verify protocols (SPF, DKIM, DMARC), and fix bottlenecks: dmarcian.com/email-header... #EmailSecurity #DMARC #EmailDeliverability

In this article we describe the intersection of the Digital Operational Resilience Act (DORA) and DMARC, showing how DMARC is one of the building blocks in achieving DORA’s objectives of making the #financial sector more digitally secure and resilient. dmarcian.com/dora-and-dma... #Financialserv…

DKIM stands for DomainKeys Identified Mail. DKIM is an open standard for email authentication used for DMARC alignment. Learn more about DKIM’s advantage of surviving forwarding, which makes it superior to SPF and a solid foundation for future DMARC implementation: dmarcian.com/what-is-dkim/ #dmar…

Cyber insurance underwriting isn't a quick checklist anymore, it's a deep technical audit. Today, insurers are increasingly expecting organisations to demonstrate mature security controls.Join us a we cover how DMARC fits in: :https://dmarcian.com/cyber-insurance/ #NIS2 #DORA #RiskManagement

“Why do DMARC reports include passes and not just failures?” DMARC reports are designed to show all sending sources and their authentication results, not just problems. Why? Learn more from the experts on our forum: forum.dmarcian.com

As #CybersecurityAwarenessMonth kicks off, we’re proud to join CISA and the NCA in highlighting the importance of cybersecurity awareness and do our part. As email remains the top vector cyberattacks, DMARC is a great way to protect your brand. Not sure where to start? dmarcian.com/getting-star...

In our latest article, dmarcian MSP Manager, Joe Garner, shares his insights on the industry and perspectives on what need to change to truly enable a great experience for long term client trust:m dmarcian.com/cybersecurit... #MSPCommunity #Partners #ManagedServices #MSSPs #DMARC #dmarcian

To combat fraud and identity theft, the Payment Card Industry (PCI DSS v4.0) now requires a layered anti-phishing strategy recommending #DMARC, #DKIM, and #SPF. Still working on it? We've created a go to resource with all you need to know: dmarcian.com/pci-requires... #PCIDSS

Most #DMARC projects don’t stall on #DNS; they stall on a person and who has no reason to answer your email’s request for help. AI won't fix human incentive problems or help you align teams. Getting an enterprise to p=reject takes a shift in mindset: dmarcian.com/dmarc-deploy...

True or False: ‘Return-Path,’ ‘envelope sender,’ ‘bounce address,’ and ‘SMTP MAIL FROM’ are commonly used to refer to the same sender identity in #SMTP. Stumped? Learn answers to questions like this and more with our FREE #DMARC Academy courses www.dmarc-academy.com

What is a CNAME record? A CNAME (Canonical Name) record is a DNS record that makes one domain and alias for another. Our latest guide covers what they are, how they work, best practices, common issues, and how to fix them fast: dmarcian.com/what-is-cnam... #DNS #cybersecurity

Curious why your #DKIM is failing? Our guide breaks down why "relaxed" canonicalization is often the solution to DKIM failures being cause for ensuring your email actually hits the inbox without compromising security: dmarcian.com/dkim-failure... #DKIM #DMARC #EmailAuthentication

Germany’s BSI declared 2025 the Year of Email Security. We re-analyzed DMARC adoption across top German businesses to see how far DMARC enforcement has progress since the BSI recommendations last year: dmarcian.com/germany-dmar... #DMARC #Cybersecurity #EMEA

How does a large global #enterprise, with multiple domains, teams, legacy systems, and more, align to implement #DMARC? 𝗝𝗼𝗶𝗻 𝘂𝘀 𝗼𝗻 𝗧𝘂𝗲𝘀𝗱𝗮𝘆, 𝟮𝟵 𝗦𝗲𝗽𝘁𝗲𝗺𝗯𝗲𝗿 𝟮𝟬𝟮𝟲 𝗮𝘁 𝟭𝟲:𝟯𝟬 𝗖𝗘𝗦𝗧 𝗳𝗼𝗿 𝗮 𝗹𝗶𝘃𝗲 𝘄𝗲𝗯𝗶𝗻𝗮𝗿 𝗮𝘀 𝘄𝗲 𝗺𝗮𝗽 𝗼𝘂𝘁 𝘁𝗵𝗲 𝗯𝗹𝘂𝗲𝗽𝗿𝗶𝗻𝘁 𝘁𝗼 𝘀𝘂𝗰𝗰𝗲𝘀𝘀𝗳𝘂𝗹 𝗗𝗠𝗔𝗥𝗖 𝗱𝗲𝗽𝗹𝗼𝘆𝗺𝗲𝗻𝘁. register.gotowebinar.com/register/665...

dmarcian's Billy Muldoon and Joe Garner sat down with Doug Green of Technology Reseller News to unpack DMARC—what it is, why MSPs need it, and where the revenue opportunities are. #ManagedServices #DMARC #EmailSecurity #AI #Podcast

Abusive SPF campaigns using dangling CNAMEs are on track to outpace previous years. Our Service Delivery Specialist, Steven I. breaks down how criminals hijack these #DNS errors for #phishing. Learn to recognize the signs and 6 ways to stop #CNAME abuse: dmarcian.com/dmarc-spf-ab...

Facing a #DMARC roadblock, a failing sender, or preparing to advance your policy but don’t know where to start? Perhaps a configuration decision in need of a second opinion, or a question that your team can’t answer confidently? He have your back: dmarcian.com/dmarc-servic...

Most #DMARC projects don’t stall on #DNS; they stall on a person and who has no reason to answer your email’s request for help. AI won't fix human incentive problems or help you align teams. Getting an enterprise to p=reject takes a shift in mindset: dmarcian.com/dmarc-deploy...

Are your email open rates declining? Our newest article explains where enterprise deliverability goes wrong, why advancing your DMARC policy (beyond p=none) requires operational alignment, and the exact steps you can take to fix it. dmarcian.com/fix-email-op... #DMARC #EmailSecurity

Stay ahead in #DMARC and email security—all in one place. Our newsletter brings you the latest insights, expert advice, and practical resources to make email safer for everyone. Join tens of thousands of subscribers building a safer email ecosystem: dmarcian.com/newsletter

Are your #SPF and #DKIM identifiers aligned? Ensuring these records align with the domain in your email’s "From" header is crucial for #DMARC compliance and improving email deliverability. Learn more about identifier alignment and how to achieve it: dmarcian.com/alignment/

Some people ask: "If I have DKIM, do I need DMARC?" The short answer is yes. In our latest article, we'll cover exactly what DKIM does, where it's protection ends and why SPF, DKIM, and DMARC must work together: dmarcian.com/why-dkim-onl... #DKIM #DMARC #SPF #dmarcian

Why is phishing still the number one threat despite advanced security controls? In our latest article dmarcian's Director of EMEA Business unit, Dermot Harnett, covers recent discussions across the European cybersecurity community: dmarcian.com/why-phishing... #DMARC

Wondering if an email source supports DMARC? Our continually updated repository features over 1,300 sources—powered by data from our source classification engine. It’s free, open to everyone, and invaluable at any stage of your #DMARC journey. dmarc.io #dmarcian

Germany’s BSI declared 2025 the Year of Email Security. We re-analyzed DMARC adoption across top German businesses to see how far DMARC enforecment has progress since the BSI recommendations last year: dmarcian.com/germany-reco... #DMARC #Cybersecurity

What is Avanan? Check Point Avanan is a cloud-based email security service used by organizations on #M365 (Microsoft 365.) How #Microsoft reports DMARC verification checks often leads to confusion among customers. Unravel the mystery! dmarcian.com/avanan-email... #EmailAuthentication #DMARC #Avanan

Why is phishing still the number one threat despite advanced security controls? In our latest article dmarcian's Director of EMEA Business unit, Dermot Harnett, covers recent discussions across the European cybersecurity community: dmarcian.com/why-phishing... #DMARC

We had a fantastic #ChannelCon26 as put on by GTIA. Thank you to everyone we met and to all who came to our booth. See you all next year. #MSPCommunity #dmarcian #Channel #DMARC #Cybersecurity

True or False: ‘Return-Path,’ ‘envelope sender,’ ‘bounce address,’ and ‘SMTP MAIL FROM’ are commonly used to refer to the same sender identity in #SMTP. Stumped? Learn answers to questions like this and more with our FREE #DMARC Academy courses www.dmarc-academy.com

The IETF published three new #DMARC specifications, RFC 9989, RFC 9990, and RFC 9991, rendering RFC 7489 obsolete— but what does this actually mean for your organization? In our latest guide we explain what's changed, what hasn't and what to do next: dmarcian.com/dmarc-rfc-up...

Did you know? You can monitor changes to your #DNS and receive notifications via #Slack, #MicrosoftTeams, and more with our Alert Central functionality. Learn more in the Alert Central overview, or log into your accounts and take a look: dmarcian.com/alert-centra... #DMARC #dmarcian

Verizon’s 19th edition of their Data Breach Investigations Report (DBIR) represents victims from 145 countries. Yet again, the number of breaches broke records and is the largest volume Verizon researchers have pored over. Take a look: dmarcian.com/2026-verizon... #Cybersecurity #AI

Many Cloud and #DNS providers offer serverless functions that allow you to host the MTA-STS policy file over HTTPS, eliminating the need to patch or maintain a full web server. Join us as we cover the best approaches to achieve this: dmarcian.com/serverless-m...

Wondering if an email source supports DMARC? Our continually updated repository features over 1,300 sources—powered by data from our source classification engine. It’s free, open to everyone, and invaluable at any stage of your #DMARC journey. dmarc.io #dmarcian